# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=(<\/?place-holder_(10|\d)>))"
test_str = (" <consumers>\n"
" <place-holder_1>\n"
" <consumer>\n"
" <val>1</val>\n"
" </consumer>\n"
" </place-holder_1>\n"
" <place-holder_2>\n"
" <consumer-info>\n"
" <val>2</val>\n"
" </consumer-info>\n"
" </place-holder_2>\n"
" <place-holder_10>\n"
" <consumer-info>\n"
" <val>2</val>\n"
" </consumer-info>\n"
" </place-holder_10>\n"
" </consumers>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.