re = /(?=(<\/?place-holder_(10|\d)>))/
str = ' <consumers>
<place-holder_1>
<consumer>
<val>1</val>
</consumer>
</place-holder_1>
<place-holder_2>
<consumer-info>
<val>2</val>
</consumer-info>
</place-holder_2>
<place-holder_10>
<consumer-info>
<val>2</val>
</consumer-info>
</place-holder_10>
</consumers>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end