import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(<\\/?place-holder_(10|\\d)>))";
final String string = " <consumers>\n"
+ " <place-holder_1>\n"
+ " <consumer>\n"
+ " <val>1</val>\n"
+ " </consumer>\n"
+ " </place-holder_1>\n"
+ " <place-holder_2>\n"
+ " <consumer-info>\n"
+ " <val>2</val>\n"
+ " </consumer-info>\n"
+ " </place-holder_2>\n"
+ " <place-holder_10>\n"
+ " <consumer-info>\n"
+ " <val>2</val>\n"
+ " </consumer-info>\n"
+ " </place-holder_10>\n"
+ " </consumers>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}