# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^0+(?!\.0+$)//gm;t' <<< "0.00
000.00
000123
00001230
00123.30"