$re = '/^0+(?!\.0+$)/m';
$str = '0.00
000.00
000123
00001230
00123.30';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;