#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^0+(?!\.0+$)"
Local $sString = "0.00" & @CRLF & _
"000.00" & @CRLF & _
"000123" & @CRLF & _
"00001230" & @CRLF & _
"00123.30"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)