use strict;
my $str = '0.00
000.00
000123
00001230
00123.30';
my $regex = qr/^0+(?!\.0+$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";