import re
regex = re.compile(r"^0+(?!\.0+$)", flags=re.MULTILINE)
test_str = ("0.00\n"
"000.00\n"
"000123\n"
"00001230\n"
"00123.30")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)