#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)<p>(.*?)<\/p>\n*[<p><\/p>]{1}"
Local $sString = "<p>Вы бы хотели иметь возможность заглянуть в будущее? </p>" & @CRLF & _
"<p></p>" & @CRLF & _
"<p>Некоторым удалось.. </p>" & @CRLF & _
"<p></p>" & @CRLF & _
"<p></p>" & @CRLF & _
"<p></p>" & @CRLF & _
"<p>Бла-бла</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")