package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)<p>(.*?)<\/p>\n*[<p><\/p>]{1}`)
var str = `<p>Вы бы хотели иметь возможность заглянуть в будущее? </p>
<p></p>
<p>Некоторым удалось.. </p>
<p></p>
<p></p>
<p></p>
<p>Бла-бла</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}