import re
regex = re.compile(r"<p>(.*?)<\/p>\n*[<p><\/p>]{1}", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("<p>Вы бы хотели иметь возможность заглянуть в будущее? </p>\n"
"<p></p>\n"
"<p>Некоторым удалось.. </p>\n"
"<p></p>\n"
"<p></p>\n"
"<p></p>\n"
"<p>Бла-бла</p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")