// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)<p>(.*?)<\/p>\n*[<p><\/p>]{1}").unwrap();
let string = "<p>Вы бы хотели иметь возможность заглянуть в будущее? </p>
<p></p>
<p>Некоторым удалось.. </p>
<p></p>
<p></p>
<p></p>
<p>Бла-бла</p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}