const regex = /<p>(.*?)<\/p>\n*[<p><\/p>]{1}/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<p>(.*?)<\\\/p>\\n*[<p><\\\/p>]{1}', 'gmi')
const str = `<p>Вы бы хотели иметь возможность заглянуть в будущее? </p>
<p></p>
<p>Некоторым удалось.. </p>
<p></p>
<p></p>
<p></p>
<p>Бла-бла</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}