import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^#.*\\r?\\n)#.*$(?!\\r?\\n#)|(?<!^#.*\\r?\\n)#.*$(?=\\r?\\n#)";
final String string = "# line1 <-- startpatern match here\n"
+ "# line2\n"
+ "# line3\n"
+ "# line4 <-- endpatern match here\n\n"
+ "# line5 <-- no match, since its single line\n"
+ "hi <-- no match\n\n"
+ "# line6 <-- startpatern match here\n"
+ "# line7 <-- endpatern match here\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}