import Foundation
let pattern = ##"(?<=^#.*\r?\n)#.*$(?!\r?\n#)|(?<!^#.*\r?\n)#.*$(?=\r?\n#)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# line1 <-- startpatern match here
# line2
# line3
# line4 <-- endpatern match here
# line5 <-- no match, since its single line
hi <-- no match
# line6 <-- startpatern match here
# line7 <-- endpatern match here
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)