use strict;
my $str = '# line1 <-- startpatern match here
# line2
# line3
# line4 <-- endpatern match here
# line5 <-- no match, since its single line
hi <-- no match
# line6 <-- startpatern match here
# line7 <-- endpatern match here
';
my $regex = qr/(?<=^#.*\r?\n)#.*$(?!\r?\n#)|(?<!^#.*\r?\n)#.*$(?=\r?\n#)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}