const regex = new RegExp('(?<=^#.*\\r?\\n)#.*$(?!\\r?\\n#)|(?<!^#.*\\r?\\n)#.*$(?=\\r?\\n#)', 'gm')
const str = `# line1 <-- startpatern match here
# line2
# line3
# line4 <-- endpatern match here
# line5 <-- no match, since its single line
hi <-- no match
# line6 <-- startpatern match here
# line7 <-- endpatern match here
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}