re = /(?<=^#.*\r?\n)#.*$(?!\r?\n#)|(?<!^#.*\r?\n)#.*$(?=\r?\n#)/m
str = '# line1 <-- startpatern match here
# line2
# line3
# line4 <-- endpatern match here
# line5 <-- no match, since its single line
hi <-- no match
# line6 <-- startpatern match here
# line7 <-- endpatern match here
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end