# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=^#.*\r?\n)#.*$(?!\r?\n#)|(?<!^#.*\r?\n)#.*$(?=\r?\n#)"
test_str = ("# line1 <-- startpatern match here\n"
"# line2\n"
"# line3\n"
"# line4 <-- endpatern match here\n\n"
"# line5 <-- no match, since its single line\n"
"hi <-- no match\n\n"
"# line6 <-- startpatern match here\n"
"# line7 <-- endpatern match here\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.