# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/'([^']+)'/Nz(Forms("meldb").$1)/g;t' <<< "la'hier'la"