use strict;
my $str = 'la\'hier\'la';
my $regex = qr/'([^']+)'/p;
my $subst = 'Nz(Forms("meldb").$1)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";