using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<type>[\w]+)(\((?<scope>[\w\-]+)\))?(?<breaking>!)?: ((?<issue>([A-Z]+-|#)[\d]+) )?(?<description>.*)";
string input = @"deploy(ingress): upgrade version
chore(deps): bump symfony/security-bundle from 5.2.6 to 5.2.7
feat(validation-rule): commit standards
chore(chart): #123456789 upgrade ingress version
ci: DSO-234 add the project parameter
feat(rule): DSO-123 commit validation
feat!: a breaking change";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}