import Foundation
let pattern = ##"^(?<type>[\w]+)(\((?<scope>[\w\-]+)\))?(?<breaking>!)?: ((?<issue>([A-Z]+-|#)[\d]+) )?(?<description>.*)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
deploy(ingress): upgrade version
chore(deps): bump symfony/security-bundle from 5.2.6 to 5.2.7
feat(validation-rule): commit standards
chore(chart): #123456789 upgrade ingress version
ci: DSO-234 add the project parameter
feat(rule): DSO-123 commit validation
feat!: a breaking change
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)