import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<type>[\\w]+)(\\((?<scope>[\\w\\-]+)\\))?(?<breaking>!)?: ((?<issue>([A-Z]+-|#)[\\d]+) )?(?<description>.*)";
final String string = "deploy(ingress): upgrade version\n"
+ "chore(deps): bump symfony/security-bundle from 5.2.6 to 5.2.7\n"
+ "feat(validation-rule): commit standards\n"
+ "chore(chart): #123456789 upgrade ingress version\n"
+ "ci: DSO-234 add the project parameter\n"
+ "feat(rule): DSO-123 commit validation\n"
+ "feat!: a breaking change";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}