import re
regex = re.compile(r"^(?<type>[\w]+)(\((?<scope>[\w\-]+)\))?(?<breaking>!)?: ((?<issue>([A-Z]+-|#)[\d]+) )?(?<description>.*)", flags=re.MULTILINE)
test_str = ("deploy(ingress): upgrade version\n"
"chore(deps): bump symfony/security-bundle from 5.2.6 to 5.2.7\n"
"feat(validation-rule): commit standards\n"
"chore(chart): #123456789 upgrade ingress version\n"
"ci: DSO-234 add the project parameter\n"
"feat(rule): DSO-123 commit validation\n"
"feat!: a breaking change")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")