re = /^(?<type>[\w]+)(\((?<scope>[\w\-]+)\))?(?<breaking>!)?: ((?<issue>([A-Z]+-|#)[\d]+) )?(?<description>.*)/m
str = 'deploy(ingress): upgrade version
chore(deps): bump symfony/security-bundle from 5.2.6 to 5.2.7
feat(validation-rule): commit standards
chore(chart): #123456789 upgrade ingress version
ci: DSO-234 add the project parameter
feat(rule): DSO-123 commit validation
feat!: a breaking change'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end