const regex = /^(?<type>[\w]+)(\((?<scope>[\w\-]+)\))?(?<breaking>!)?: ((?<issue>([A-Z]+-|#)[\d]+) )?(?<description>.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<type>[\\w]+)(\\((?<scope>[\\w\\-]+)\\))?(?<breaking>!)?: ((?<issue>([A-Z]+-|#)[\\d]+) )?(?<description>.*)', 'gm')
const str = `deploy(ingress): upgrade version
chore(deps): bump symfony/security-bundle from 5.2.6 to 5.2.7
feat(validation-rule): commit standards
chore(chart): #123456789 upgrade ingress version
ci: DSO-234 add the project parameter
feat(rule): DSO-123 commit validation
feat!: a breaking change`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}