# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\d|^)(?<!(?<![^\W_])(?:sha|md))(?=\d)|(?<=\d)(?!\d|$)|_/ /gm;t' <<< "Aisha256
ai_sha256
test123
84test
test md5
sha256
word two sha1
w0rd
test_md5
sha256
md5"