const regex = /(?<!\d|^)(?<!(?<![^\W_])(?:sha|md))(?=\d)|(?<=\d)(?!\d|$)|_/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d|^)(?<!(?<![^\\W_])(?:sha|md))(?=\\d)|(?<=\\d)(?!\\d|$)|_', 'gm')
const str = `Aisha256
ai_sha256
test123
84test
test md5
sha256
word two sha1
w0rd
test_md5
sha256
md5`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);