#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\d|^)(?<!(?<![^\W_])(?:sha|md))(?=\d)|(?<=\d)(?!\d|$)|_"
Local $sString = "Aisha256" & @CRLF & _
"ai_sha256" & @CRLF & _
"test123" & @CRLF & _
"84test" & @CRLF & _
"test md5" & @CRLF & _
"sha256" & @CRLF & _
"word two sha1" & @CRLF & _
"w0rd" & @CRLF & _
"test_md5" & @CRLF & _
"sha256" & @CRLF & _
"md5"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)