import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d|^)(?<!(?<![^\\W_])(?:sha|md))(?=\\d)|(?<=\\d)(?!\\d|$)|_";
final String string = "Aisha256\n"
+ "ai_sha256\n"
+ "test123\n"
+ "84test\n"
+ "test md5\n"
+ "sha256\n"
+ "word two sha1\n"
+ "w0rd\n"
+ "test_md5\n"
+ "sha256\n"
+ "md5";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}