import re
regex = re.compile(r"(?<!\d|^)(?<!(?<![^\W_])(?:sha|md))(?=\d)|(?<=\d)(?!\d|$)|_", flags=re.MULTILINE)
test_str = ("Aisha256\n"
"ai_sha256\n"
"test123\n"
"84test\n"
"test md5\n"
"sha256\n"
"word two sha1\n"
"w0rd\n"
"test_md5\n"
"sha256\n"
"md5")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)