re = /(?<!\d|^)(?<!(?<![^\W_])(?:sha|md))(?=\d)|(?<=\d)(?!\d|$)|_/m
str = 'Aisha256
ai_sha256
test123
84test
test md5
sha256
word two sha1
w0rd
test_md5
sha256
md5'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result