using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"amount:(\d+[,.]\d+(?:[.,]\d+)?)";
string input = @"el amount:762,50 es
1.843,75
1,75";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}