package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)amount:(\d+[,.]\d+(?:[.,]\d+)?)`)
var str = `el amount:762,50 es
1.843,75
1,75`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}