$re = '/amount:(\d+[,.]\d+(?:[.,]\d+)?)/m';
$str = 'el amount:762,50 es
1.843,75
1,75';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);