import re
regex = re.compile(r"amount:(\d+[,.]\d+(?:[.,]\d+)?)", flags=re.MULTILINE)
test_str = ("el amount:762,50 es\n"
"1.843,75\n"
"1,75")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")