re = /amount:(\d+[,.]\d+(?:[.,]\d+)?)/m
str = 'el amount:762,50 es
1.843,75
1,75'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end