#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^title="([^"]+)")\s*\R(^artist="([^"]+)")\s*(?:\R|\z)"
Local $sString = "title="title1" " & @CRLF & _
"artist="artist1" " & @CRLF & _
"title="title2" " & @CRLF & _
"artist="artis2" " & @CRLF & _
"title="title3" " & @CRLF & _
"artist="artist3""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")