import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^title=\"([^\"]+)\")\\s*\\R(^artist=\"([^\"]+)\")\\s*(?:\\R|\\z)";
final String string = "title=\"title1\" \n"
+ "artist=\"artist1\" \n"
+ "title=\"title2\" \n"
+ "artist=\"artis2\" \n"
+ "title=\"title3\" \n"
+ "artist=\"artist3\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}