$re = '/(^title="([^"]+)")\s*\R(^artist="([^"]+)")\s*(?:\R|\z)/m';
$str = 'title="title1"
artist="artist1"
title="title2"
artist="artis2"
title="title3"
artist="artist3"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);