re = /(^title="([^"]+)")\s*\R(^artist="([^"]+)")\s*(?:\R|\z)/m
str = 'title="title1"
artist="artist1"
title="title2"
artist="artis2"
title="title3"
artist="artist3"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end