// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(^title="([^"]+)")\s*\R(^artist="([^"]+)")\s*(?:\R|\z)"#).unwrap();
let string = "title=\"title1\"
artist=\"artist1\"
title=\"title2\"
artist=\"artis2\"
title=\"title3\"
artist=\"artist3\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}