package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^title="([^"]+)")\s*\R(^artist="([^"]+)")\s*(?:\R|\z)`)
var str = `title="title1"
artist="artist1"
title="title2"
artist="artis2"
title="title3"
artist="artist3"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}