const regex = /^[^:\r\n]+:\h*(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^:\\r\\n]+:\\h*(.*)', 'gm')
const str = `afghanistan : Afghanistan
albania : Albania
algeria : Algeria
andorra : Andorra
angola : Angola`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);