#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^http:(.*)"
Local $sString = "http://mmc.com/events"
Local $sSubst = "https:$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)