const regex = /^http:(.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^http:(.*)', '')
const str = `http://mmc.com/events`;
const subst = `https:$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);