use strict;
my $str = 'http://mmc.com/events';
my $regex = qr/^http:(.*)/p;
my $subst = 'https:$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";