using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!(([^""]*""){2})*[^""]*$)\n+";
string substitution = @" ";
string input = @"cztery;""pięć
"";sześć
uno;""due;due"";""tres
""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}