re = /(?!(([^""]*""){2})*[^""]*$)\n+/
str = 'cztery;"pięć
";sześć
uno;"due;due";"tres
"'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result